This project is read-only.
1

Closed

RESOLVED - The command "WCFAsyncQueryableServicesServer Model1.edmx All" Fails with fatal exception

description

WAQS is now working properly - two things that I changed:
1) used the exact same project types used in demo video (http://www.dailymotion.com/video/xuc1jb_waqs-application-scaffolding_tech)
2) set all quoted values to be single-quote and then double-quote as it is listed in the "How to use WAQS?" documentation (http://msmvps.com/blogs/matthieu/archive/2013/12/13/how-to-use-waqs.aspx)

Sidenote: the auto-complete for my environment [en-us] set the values to just be double-quoted. I had to explicitly go back and put single quotes around the double quotes in the PM Console.

--original
When launching the command 'WCFAsyncQueryableServicesServer "c:\path\to\edmx\Model1.edmx" All' from within the package manager console, a command window will open, but display in red "Object reference not set to an instance of an object". When the command window is closed, the following error message is displayed:

_Exception calling "AddFromFile" with "1" argument(s): "Cannot find file "c:\dev\WaqsTest\WaqsTest\WAQS.Model1\Model1.Server.waqs"."
At C:\dev\WaqsTest\packages\WCFAsyncQueryableServices.Server.1.9.1.142\tools\WCFAsyncQueryableFunctionsServer.psm1:258 char:48
  • $null = (Get-Project).ProjectItems.AddFromFile <<<< ((Join-Path $waqsDirectory ($edmxName + ".Server.waqs")))
    • CategoryInfo : NotSpecified: (:) [], MethodInvocationException
    • FullyQualifiedErrorId : ComMethodTargetInvocation
Exception calling "AddFromFile" with "1" argument(s): "Cannot find file "c:\dev\WaqsTest\WaqsTest\WAQS.Model1\Model1.Server.tt"."
At C:\dev\WaqsTest\packages\WCFAsyncQueryableServices.Server.1.9.1.142\tools\WCFAsyncQueryableFunctionsServer.psm1:259 char:48
  • $null = (Get-Project).ProjectItems.AddFromFile <<<< ((Join-Path $waqsDirectory ($edmxName + ".Server.tt")))
    • CategoryInfo : NotSpecified: (:) [], MethodInvocationException
    • FullyQualifiedErrorId : ComMethodTargetInvocation
_
It creates 3 folders that are all empty: DTO, Specifications, WAQS.Model1. I have attempted this multiple times, running visual studio as both administrator and not as an administrator. but have repeatedly ran into this issue.

Here is my environment info:
  • Windows 7
  • Visual Studio 2012 w/ update 4
  • WCFAsyncQueryableServices visual studio extension
  • CommonServiceLocator 1.0
  • EntityFramework 5.0.0
  • RoselynGACDeploy 1.0.6
  • Unity 3.0.1304.1
  • WCFAsyncQueryableServices.Server.1.9.1.142
I have also attached my edmx, in case it is helpful. Please let me know if there is anything else I can provide that will be helpful.

file attachments

Closed Apr 9, 2014 at 11:49 PM by MatthieuMEZIL

comments

MatthieuMEZIL wrote Feb 21, 2014 at 9:14 PM

Thank you reporting me. And it's great you was able to fix it yourself.
Anyway, I will take a look on it in order to fix it.

wrote Apr 9, 2014 at 11:49 PM

wrote Apr 9, 2014 at 11:49 PM